请选择 进入手机版 | 继续访问电脑版

雨滴科技技术论坛

 找回密码
 立即注册
查看: 36|回复: 1

linux qt程序运行问题

[复制链接]

59

主题

246

帖子

1593

积分

金牌会员

Rank: 6Rank: 6

积分
1593
扫一扫,手机访问本帖
发表于 2019-10-7 23:41:46 | 显示全部楼层 |阅读模式
在重新制作根文件系统之后,发现编译好的qt程序一直不能运行,报错如下:
  1. qt.qpa.plugin: Could not find the Qt platform plugin "eglfs" in ""
  2. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the applicati.

  3. Available platform plugins are: linuxfb, minimal, offscreen, vnc.
复制代码
解决方法1:直接在运行qt程序的时候在后面添加:-platform linuxfb.
解决方法2:配置export QT_QPA_PLATFORM=linuxfb:fb=/dev/fb0
这样就可以运行.

回复

使用道具 举报

367

主题

1886

帖子

9204

积分

版主

Rank: 7Rank: 7Rank: 7

积分
9204
发表于 5 天前 | 显示全部楼层
现在组态屏,采用QT做的吗?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

在线客服
在线咨询
咨询热线
0755-26787502-8006/8016
扫一扫二维码
直接访问本站

QQ|Archiver|手机版|小黑屋|雨滴科技  

GMT+8, 2019-10-18 18:51 , Processed in 0.095315 second(s), 25 queries , Gzip On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表